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Introduction
The Dolphin 70e Black OS Upgrade Kit (70E-OS-UPGRADE-01) provides businesses with the ability to convert their existing 
devices running Windows® Embedded Handheld 6.5 operating systems to Android 4.0™ devices. 

Important Facts to Consider Before Upgrading
Permanency of the Upgrade

The OS upgrade is permanent. The terminal operating system (OS) cannot be changed back to Windows Embedded 
Handheld 6.5 once the conversion to Android 4.0 is complete.

Button Hardware

The 70E-OS-UPGRADE-01 kit does not include hardware to change the buttons on the terminal. Honeywell offers additional 
options if you require both hardware and software terminal configurations for Android 4.0. 

• Custom Model Configurations

Contact a Honeywell representative for information on custom model configurations specifically designed to support 
future conversion to Android 4.0.

• Honeywell Service Center Hardware Upgrades

Honeywell Service Centers can replace the buttons in a previously purchased WEH terminal with buttons designed for 
Android devices. Contact a Honeywell representative for additional information.

Button Maps

Note: Refer to the Quick Start Guide or User’s Guide relevant for your Dolphin model for additional information. 
Product guides are available for download at www.honeywellaidc.com.

Quick Overview of the OS Upgrade Process

What You Need to Perform the OS Upgrade
• Dolphin 70e Black OS Upgrade Kit, PN 70E-OS-UPGRADE-01 (1 per terminal)

The upgrade kit includes a single Android OS license key. You must purchase one kit for each terminal being upgraded. 

• A microSD™ or microSDHC™ memory card (1 per terminal)

A memory card is required to perform the OS upgrade and for applications running on the terminal after the upgrade is 
complete. Terminals powered by Android include applications that utilize the memory card to store files and application 
data. Memory card use is required to avoid potential application errors or possible data loss. 

Window Embedded Handheld 6.5 
Device Button Map

Android 4.0 
Device Button Map

Back EndHomeSend Scan Back SearchMenuHome Scan
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Memory Card Specifications

Honeywell recommends the use of Single Level Cell (SLC) industrial grade microSD or microSDHC memory cards with 
Dolphin terminals for maximum performance and durability. Contact a Honeywell sales representative for additional infor-
mation on qualified memory card options.

• Internet access for file downloads

During the upgrade process you are required to download files from the Honeywell Scanning & Mobility FTP Site. 
To gain access to the site, contact Technical Support or request the information from your local sales representative when 
ordering the upgrade kit.

• Minimum Software Requirements on the Dolphin 70e Black terminal running Windows Embedded Handheld 6.5

• Latest WWAN Radio (SL9090 or SL8092) Firmware. Contact Technical Support (page 7-15) for details.
• Honeywell SDKNC version 810.1996 or greater is required to run the Serial Number Collection Tool on the terminal. 

Note: Touch Start > Power Tools > SysInfo.  The SDKNC version is listed in the Value column under the 
\IPSM\Honeywell\AutoInstall\*.* heading (e.g., SDKNC_810.1996.CAB).
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Step 1: Create a Serial Number File
Why Serial Numbers are Required to Place an OS Upgrade Order
When you purchase an OS upgrade kit, Honeywell creates a unique Android OS license key linked to the serial number of the 
Dolphin 70e Black terminal being upgraded. A valid license key is required to run Android on the Dolphin 70e Black. 

Note: Submitting the serial number also ensures authorized Honeywell service centers will return the device to you with the 
correct OS installed if service is required on the terminal. 

How to Find the Terminal Serial Number
The terminal serial number (S/N) is referenced in four locations:

• On the serial number label located under the battery inside the battery well.
• On the serial number label attached to the original box containing the terminal.

• On the HSM System Information screen. Touch  > Settings > System > HSM SystemInfo.

• On the Power Tools System Information screen. Touch  > Power Tools > SysInfo.

Options for Serial Number Collection
When ordering multiple upgrade kits, you need to supply a comma separated value file (*.csv) of the terminal serial numbers 
included in the order to the sales representative. Honeywell provides two options to help you gather the information into the 
appropriate file format.

Option 1: 
1. Download the Serial Number OS Upgrade File (SN.csv) from the Dolphin 70e Black product page at

 www.honeywellaidc.com.

2. Open the SN.csv file using Microsoft® Excel® or Microsoft Excel Mobile.

3. Add the serial numbers of the terminals included in the upgrade order to the first column of the sheet.

4. Save the file. Do not change the file name or format.

5. Provide the SN.csv file with your order to a Honeywell sales representative.

Option 2: 
Honeywell provides a free Serial Number Collection Tool for download and use if you have a large number of terminals 
requiring upgrade kits. Once installed on a Dolphin 70e Black terminal, the tool can be used to automatically populate a 
SN.csv file by scanning the serial number bar codes of the terminals to be included in the order. 

See Using the Honeywell Serial Number Collection Tool on page 4.
3
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Using the Honeywell Serial Number Collection Tool

Minimum Software Requirements
Honeywell SDKNC version 810.1996 or greater is required to run the Serial Number Collection Tool on the terminal.

Note: Touch Start > Power Tools > SysInfo.  The SDKNC version is listed in the Value column under the 
\IPSM\Honeywell\AutoInstall\*.* heading (e.g., SDKNC_810.1996.CAB).

Downloading and Installing the Tool
1. Download the tool to a workstation PC.

1.1 Go to www.honeywellaidc.com and navigate to the Software tab on the Dolphin 70e Black product page. 

1.2 Under Tools and Utilities, select Honeywell Serial Number Collection Tool.

1.3 Fill out the online form, accept the End User License Agreement, and then select Download.

2. Copy the SNSetupTool_x.xx.CAB file from the workstation PC to the Dolphin 70e Black terminal.

3. On the terminal, touch  > File Explorer.

4. Navigate to the location where the SNSetupTool_x.xx.CAB file was saved and touch the file to start the installation.

5. Touch Install to accept the default location, Device.

6. Touch OK.

Using the Tool on the Terminal

1. Touch  > File Explorer > Program Files > SNCollectTool.

2. Touch SNCollectTool to open and run the tool.

• A SN.csv file is automatically created and saved in the My Device/SN folder on the terminal.
• The serial number of the terminal being used is logged into the SN.csv file.
• The SN Results display appears.
• The imager is activated (ScanWedge is enabled).

3. To add additional serial numbers to the SN.csv file, perform one of the following actions:

• scan the bar code located on the serial number label inside the battery well of the terminal,
• scan the bar code located on the original box that contained terminal, or
• copy the SN.csv file to a PC, then open the file and manually add the serial numbers of the terminals.

Note: Pressing the Scan button (center button) on the front of the terminal or the left and right side buttons on the 
terminal to initiates a scan.

The results of the current scan session are simultaneously displayed on the screen and logged into the SN.csv file.
4
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Do not scan the serial number of the terminal running the SNCollectTool or the number will appear twice in the 
SN.csv file. By default, the terminal serial number is added to the SN.csv file when the SNCollectTool opens.

Note:  The display does not always reflect the full content of the SN.csv file. If you close and then reopen the tool 
or select Clear Display from the File menu, the display is cleared of data but the content of the SN.csv is not 
affected. The serial numbers from previous scans remain saved the SN.csv file but the numbers are no longer 
visible on the terminal screen. 

4. Touch File > Exit to close the tool and disable ScanWedge.

5. Provide the SN.csv file to a Honeywell sales representative with your OS upgrade kit order.

File Menu
Touch File on the tile bar to access additional menu options.

Exit
Select Exit to disable ScanWedge and exit the tool.

Clear Display
Select Clear Display to clear the SN Results displayed on the terminal screen.  

Note: Clearing the display does not affect the data collected in the SN.csv file.

Remove all SN 
Select Remove all SN and then OK to erase the serial number data collected in the SN.csv file.

Note: Remove all SN does not delete the SN.csv file from the terminal. Only the serial number data in the SN.csv file 
is erased.

File Menu

Displays the scan results 
for the current tool session.   
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Step 2: Place the Order and Receive New License(s)
What to Provide When Ordering
Contact a Honeywell sales representative to place your kit order and request a License.csv file. 

The sales representative will request the following from you:

• The SN.csv file created in Step 1 (see page 3).
• The quantity of 70E-OS-UPGRADE-01 kits you are ordering. 

Note: Each kit includes the software and licensing required to transfer the OS of one Dolphin 70e Black terminal. You 
must order a kit for each device being upgraded.

• A valid email address where a License.csv file can be sent to you.

In addition to the upgrade kit, you may want to order memory cards for the terminal(s) being upgraded. A microSD or microSDH 
card is required to perform the OS upgrade and is needed for some applications to run properly on the terminal after the 
upgrade is complete.  Honeywell offers several qualified memory card options, which can be added to the kit order.

Memory Card Specifications

Honeywell recommends the use of Single Level Cell (SLC) industrial grade microSD or microSDHC memory cards with 
Dolphin terminals for maximum performance and durability.

Receiving a New License File
Once the initial sales order process is completed, OS licenses are created for the terminal serial numbers listed in the SN.csv 
file. The new licenses are provided to you in the form of a single License.csv file. 

Important: Save the License.csv file in a safe location. Do not change the name or format of the file. The upgrade 
process cannot be completed without a valid License.csv file from Honeywell. 
7
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Step 3: Prepare the Terminal for Upgrade
Install the microSD Card in the Terminal
Refer to the Quick Start Guide or User’s Guide relevant for your Dolphin model for information on installing a microSD card in 
the terminal. Product guides are available for download at www.honeywellaidc.com.

Remove the Microsoft® Certificate of Authenticity (COA) Label on the Terminal
The Microsoft COA label must be removed from the terminal since the upgrade removes the Microsoft Windows Embedded 
Handheld operating system and associated license. In addition, removing the COA label also ensures authorized Honeywell 
service centers will return the device to you with the correct OS installed if service is required on the terminal.

1. Press and hold the Power button until the Phone Options menu displays.

2. Touch POWER OFF.

3. Remove the battery door and battery. Refer to the Quick Start Guide or User’s Guide relevant for your Dolphin model for 
additional information.

Note: Product guides are available for download at www.honeywellaidc.com.

4. Locate and remove the COA label in the battery well.

5. Insert the battery and install the battery door. The terminal begins booting as soon as power is applied.

Upgrade the Terminal to the Latest WWAN Radio (SL9090 or SL8092) Firmware 
Verify the terminal is running the latest WWAN radio firmware version before attempting to upgrade the terminal to an Android 
OS. Contact technical support for information on the latest radio firmware release.

To find out what radio firmware version is running on the terminal:

Touch  > Settings > System > RIL or touch   > DolphinCM. Select the Profile tab and then Refresh.

To upgrade the WWAN radio (SL9090 or SL8092) firmware on the terminal:

1. Contact Honeywell Technical Support to request access to the Honeywell Scanning & Mobility FTP site.

2. Download the latest WWAN radio (SL9090 or SL8092) firmware update to a workstation PC.

2.1 Access the Honeywell Scanning & Mobility FTP site. 

2.2 Click Mobility > WEH6.5.

2.3 Select the terminal configuration (e.g., CHS, CHT, FRA, or WWE ).

2.4 Click 70e Black.

2.5 Select either BT_WLAN, GSM Only (SL8092) or GSM_CDMA (SL9090) depending on the terminal model.

2.6 Download the latest radio firmware update file (e.g., SL9090_Firmware_x.xx.CAB or 
SL8092_Firmware_x.xx.CAB) file.

COA Label COA Label

Model Type: IP67, Locking Battery Door Model Type: IP54, Non-Locking Battery Door
9
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3. Copy the radio firmware .CAB file to the IPSM folder on the terminal.  

Note: Do not copy the file into the AutoInstall folder or the upgrade fails.

4. On the terminal, touch  > File Explorer > IPSM. 

5. Touch the radio firmware .CAB file start the update. 

6. Touch Install to accept the default location, Device.

7. Touch OK.

8. Once the installation is complete, delete the radio update file (e.g., SL9090_Firmware_xxx.CAB or 
SL8092_Firmware_xxx.CAB).
10



Step 4: Prepare the microSD Card
Download the Latest Android OS Files
1. Access the Honeywell Scanning & Mobility FTP Site. 

2. Click Mobility > Android 4.0.x (Black) > 70e Black.

3. Select the terminal configuration (e.g., WWE or CHS).

4. Download the latest Android OS kernel (e.g., DBLACKAD_x.xx.zip) and the md5 checksum file 
(e.g., x.xx-md5sum.txt) to a workstation PC.

5. Click SD Image > Honeywell > AutoInstall.

6. Download the latest CommonES_Android files and service pack (if available) to a workstation PC. 

• Honeywell_CommonES_Android_Demos_x.xx.zip
• Honeywell_CommonES_Android_PowerTools_x.xx.zip
• Honeywell_CommonES_Android_SDK_Runtime_x.xx.zip
• Service Pack (if required)

Copy the Android OS Files to the microSD Card
Memory Card Specifications

Honeywell recommends the use of Single Level Cell (SLC) industrial grade microSD or microSDHC™ memory cards with
Dolphin terminals for maximum performance and durability. Contact a Honeywell sales representative for additional information 
on qualified memory card options.

1. Format the microSD/SDHC card to FAT or FAT32.

2. Save the DBLACKAD_x.xx.zip and x.xx-md5sum.txt files under the root directory of the microSD/SDHC card.

3. Create a folder named License under the root directory of the microSD/SDHC card.

4. Save the License.csv file (provided by Honeywell) in the License folder.

5. Create a folder named Honeywell under the root directory of the microSD/SDHC card.

6. Create a folder named Autoinstall in the Honeywell folder.

7. Save the CommonES_Android and service pack (if available) files in the Honeywell/Autoinstall folder on the 
microSD/SDCH card.

• Honeywell_CommonES_Android_Demos_x.xx.zip
• Honeywell_CommonES_Android_PowerTools_x.xx.zip
• Honeywell_CommonES_Android_SDK_Runtime_x.xx.zip
• Service Pack (if required)

Note: You may also save custom application files (*.zip) in the Honeywell/Autoinstall folder to have the applications install 
automatically during the upgrade.

Sample microSD Card
11
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Step 5: Complete the Upgrade
Download and Copy the Upgrade File to the Terminal
1. Download the DBLACKAD_OS_Swap_x.xx.CAB upgrade file to a workstation PC.

1.1 Access the Honeywell Scanning & Mobility FTP Site.

1.2 Click Mobility > Android 4.0.3 (Black) > 70e Black > Windows to Android. 

2. Copy the DBLACKAD_OS_Swap_x.xx.CAB to the root /Honeywell/Autoinstall folder on the terminal.

Note: The upgrade will not automatically initiate after a Hard Reset (Reboot) if the CAB file is saved in the 
IPSM/Honeywell/Autoinstall folder instead of the root /Honeywell/Autoinstall folder on the terminal. 
Either move the file to the correct location and reboot or use File Explorer on the terminal to locate and touch the 
DBLACKAD_OS_Swap_x.xx.CAB file to initiate the upgrade manually.

Perform a Hard Reset (Reboot) to Complete the Upgrade
1. Ensure the terminal is running on external power.

2. Press and hold the Power button on the terminal until the Phone Options menu displays.

3. Touch HARD RESET.

Troubleshooting the Upgrade
Try the following options if the terminal displays one of the errors listed below, cancels the upgrade, and leaves the Windows 
Embedded Handheld OS intact.

“Invalid SN Error”
1. Verify the following items are correct.

• The License.csv file is saved in the correct location (see page 11).
• The License.csv file name and file type (*.csv) are correct.
• The License.csv file contains the correct serial number of the terminal you are upgrading.

2. Replace the file with a new copy of the original License.csv file provided by Honeywell. 

3. If you still receive the error after replacing the License.csv file, contact technical support. 

Note: If you do not have a License.csv file, contact a Honeywell sales representative for information on how to 
purchase a Dolphin 70e Black upgrade kit and acquire a valid License.csv for your terminal.

“Invalid License Error”
1. The license key in the License.csv file may be invalid or missing. Replace the file with a new copy of the original 

License.csv file provided by the Honeywell. 

2. If you still receive the error after replacing the file, contact technical support. 

Note: If you do not have a License.csv file, contact a Honeywell sales representative for information on how to 
purchase a Dolphin 70e Black upgrade kit and acquire a valid License.csv for your terminal.

“Error md5 checksum for DBLACKAD_x.xx.zip”
1. Verify the following items are correct.

• The xxx-md5sum.txt file is saved in the correct location (see page 11).
• The xxx-md5sum.txt version number matches the DBLACKAD_x.xx.zip kernel version number

(e.g., DBLACKAD_41.13.zip matches 41.13-md5sum.txt).

2. Replace the file with a new copy of the original file downloaded from the Honeywell Scanning & Mobility FTP Site. 

3. If you still receive the error after replacing the file, contact technical support. 
13



Error “Multi Valid UPG Files are available” 
1. Verify only one instance of the DBLACKAD_x.xx.zip OS kernel file is saved on the microSD/SDHC. 

Error “Failed to find Valid UPG File”  
1. Verify the DBLACKAD_x.xx.zip file is saved in the correct location on the microSD/SDHC card  (see page 11).

2. Replace the file with a new copy of the original file downloaded from the Honeywell Scanning & Mobility FTP Site. 

3. If you still receive the error after replacing the file, contact technical support. 
14



Customer Support
Product Service and Repair
Honeywell International Inc. provides service for all of its products through service centers throughout the world. To obtain war-
ranty or non-warranty service, please visit www.honeywellaidc.com and select Support > Contact Service and Repair to see 
your region's instructions on how to obtain a Return Material Authorization number (RMA #). You should do this prior to return-
ing the product.

Technical Assistance
If you need assistance installing or troubleshooting your device, please contact us by using one of the methods below:

Knowledge Base: www.hsmknowledgebase.com

Our Knowledge Base provides thousands of immediate solutions. If the Knowledge Base cannot help, our Technical Support 
Portal (see below) provides an easy way to report your problem or ask your question.

Technical Support Portal: www.hsmsupportportal.com

The Technical Support Portal not only allows you to report your problem, but it also provides immediate solutions to your techni-
cal issues by searching our Knowledge Base.  With the Portal, you can submit and track your questions online and send and 
receive attachments. 

Web form: www.hsmcontactsupport.com

You can contact our technical support team directly by filling out our online support form.  Enter your contact details and the 
description of the question/problem.

Telephone: www.honeywellaidc.com/locations

For our latest contact information, please check our website at the link above.
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Software
End User License Agreement

This License Agreement (“Agreement”) is a legal agreement between you and Honeywell International Inc. (“Licensor”) regard-
ing the associated software (“Software”), which may include software owned by Honeywell and software licensed by Honeywell 
from its software suppliers (“Suppliers”).

The Agreement also applies to any updates, upgrades, revisions, patches, bug fixes, new versions, supplements, and other 
modifications to, as well as Internet-based services and support services for, this software, unless other terms accompany 
those items. If so, those terms apply. 

By installing, activating, or using the Software, you agree to be bound by the terms and conditions of this Agreement. If you do 
not agree to be so bound, you may not install the Software or, if the Software is already installed, you must promptly remove it. 
The Software and any accompanying materials (including, without limitation, any images, photographs, animations, video, 
audio, music, text, and applets incorporated into the Software, the accompanying media, and printed materials) are owned by 
Licensor and its Suppliers and protected under U.S. and international copyright laws, and may be protected under additional 
intellectual property laws. The Software is licensed, not sold, and Licensor and its Suppliers retain all right, title, and interest 
therein other than those rights specifically granted to you under this Agreement. You accept responsibility for selection of the 
Software to achieve your intended results, and for installation, activation, use of, and results obtained from, the Software.

LICENSE: Licensor hereby grants you a non-exclusive License to use this Software, without right of sub-license, only in object 
or executable code form. The Software may be included in a software package intended for installation in devices both of Licen-
sor and one or more other manufacturers, but may only be run in, or for use with, Licensor’s products (“Products”). You may not 
rent, lease, or lend the Software. You may permanently transfer rights under this Agreement only as part of a permanent sale or 
transfer of the Products, and only if the recipient accepts this Agreement. If the Software is an upgrade, any transfer must also 
include all prior versions of the Software. You agree that the Software and any additional materials specific to the Software pro-
vided under this Agreement are and shall at all times remain the sole and exclusive property of Licensor and its Suppliers. 
Unauthorized copying of the Software is expressly forbidden. The Software may be patent-pending and/or patented; please 
refer to documentation accompanying the product, including labels and user guides, for specifics. You may be held legally 
responsible for any infringement of copyright or other intellectual property rights caused by your failure to abide by this Agree-
ment. If the Software is identified by Licensor as a demonstration version, Licensee may use the Software on multiple Products 
or platforms. If the Software is provided by Licensor as other than a demonstration version, Licensee may use the Software only 
on or with a single Product. User's guides and programming guides for the Software that are provided by Licensor in either hard 
or electronic copy may be copied and distributed. The rights granted by this Agreement do not give you rights to implement pat-
ents or other intellectual property of Licensor or its Suppliers.

OPEN SOURCE: If you use Open Source software in conjunction with the Software, you represent and warrant that your use 
will not: (i) create, or purport to create, obligations on Licensor or its Suppliers with respect to the Software; or (ii) grant, or pur-
port to grant, to any third party any rights to Software that are not permitted by this Agreement; or (iii) grant, or purport to grant, 
to any third party any immunities with respect to Licensor’s or its Suppliers’ proprietary rights.

Any Open Source software listed under this Agreement is listed only for your convenience and solely for information purposes, 
and, if licensed, is licensed to you only under the terms set forth in the corresponding Open Source License, which you may find 
on the Internet at the designated URL, or in the header files of such software.

YOUR REPRESENTATIONS and WARRANTIES REGARDING USE OF THE SOFTWARE: You represent and warrant that 
you shall not do any of the following, and shall not cause or knowingly allow others to, do any of the following:

(a)  use the Software unlawfully; 

(b)  place harmful software on the Software or use it in connection with the Software, including but not limited to, the 
generation or dissemination of computer viruses, Trojan horses, time bombs, denial of service attacks, key-logging and 
other monitoring software, worms, logic bombs, or other harmful code or programs;

(c)  use the Software, by itself or in conjunction with harmful software, to:

(i) negatively impact the operation or performance of the Software, 

(ii) negatively impact the safety, security, or privacy of users or owners of the Software, 

(iii) negatively impact the operation or performance of the networks with which the Software may interact (“Networks”), 

(iv) attempt unauthorized use of or access to such Networks, or to any service, data or account, or,

(v) cause harm to the Software, the Products with which they are used, or the Networks, or impair their use by others.

RESTRICTIONS: You may not use, print, copy, or display the Software in whole or in part except as expressly permitted in writ-
ing. You may not modify, translate, alter, create derivatives of, "reverse compile," decompile, merge with another program, or 
otherwise derive the source code for the Software, or defeat any "keys" or codes controlling authorized access or functionality, 
nor allow others to do the same. 

NOTE ON JAVA SUPPORT: The Software may contain support for programs written in Java. Java technology is not fault toler-
ant and is not designed, manufactured, or intended for use or resale as online control equipment in hazardous environments 
requiring fail-safe performance, such as in the operation of nuclear facilities, aircraft navigation or communication systems, air 
traffic control, direct life support machines, or weapons systems, in which the failure of Java technology could lead to directly to 
death, personal injury, or severe physical or environmental damage. 
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INDEMNIFICATION: Licensee agrees to defend, indemnify, and hold harmless Licensor and its officers, directors, employees, 
and successors and assigns against any and all claims, demands, causes of action, losses, liabilities, damages, costs and 
expenses, incurred by Licensor (including but not limited to costs of defense, investigation, and reasonable attorney’s fees) aris-
ing out of, resulting from, or related to failure to comply with the terms of this Agreement, including but not limited to (1) the 
clauses directed to Open Source, Malware, and Restrictions, (2) unauthorized use or disclosure of Software, and (3) use of 
Software in combination with software, hardware, systems, or other items not provided by Licensor. 

DISCLAIMERS AND LIMITATIONS OF LIABILITY: THE SOFTWARE IS NOT FAULT TOLERANT, AND IS PROVIDED AS IS 
AND WITH ALL FAULTS. TO THE MAXIMUM EXTENT PERMITTED BY APPLICABLE LAW, AND EXCEPT AS OTHERWISE 
EXPRESSLY SET FORTH IN THIS AGREEMENT OR, WITH RESPECT TO THE OPEN SOURCE SOFTWARE LISTED FOL-
LOWING, EACH RESPECTIVE OPEN SOURCE LICENSE, LICENSOR, ITS SUPPLIERS AND LICENSORS, AND ANY OPEN 
SOURCE CONTRIBUTORS (1) DISCLAIM ANY AND ALL PROMISES AND REPRESENTATIONS WITH RESPECT TO THE 
SOFTWARE, INCLUDING ITS CONDITION, ITS CONFORMITY TO ANY REPRESENTATION OR DESCRIPTION, AND THE 
EXISTENCE OF ANY LATENT OR PATENT DEFECTS, (2) DISCLAIM ALL WARRANTIES, WRITTEN OR ORAL, EXPRESS, 
IMPLIED, OR STATUTORY, INCLUDING WITHOUT LIMITATION ANY IMPLIED WARRANTIES OF MERCHANTABILITY, FIT-
NESS FOR PARTICULAR PURPOSE, TITLE, AND NON-INFRINGEMENT OF THIRD-PARTY RIGHTS; AND, (3) SHALL 
HAVE NO LIABILITY FOR ANY DIRECT, INDIRECT, SPECIAL, CONSEQUENTIAL, OR INCIDENTAL DAMAGES ARISING 
FROM OR IN CONNECTION WITH THE USE OR PERFORMANCE OF THE SOFTWARE. THIS LIMITATION SHALL APPLY 
EVEN IF ANY REMEDY FAILS OF ITS ESSENTIAL PURPOSE. IN NO EVENT SHALL LICENSOR OR ITS SUPPLIERS BE 
LIABLE FOR ANY AMOUNT IN EXCESS OF (1) THE INITIAL LICENSE FEE THAT LICENSOR RECEIVED FROM YOU FOR 
THE PRODUCTS, IN THE CASE OF LICENSOR, OR (2) U.S. TWO HUNDRED AND FIFTY DOLLARS (U.S. $250.00), IN THE 
CASE OF LICENSOR’S SUPPLIERS.. ALL RISK AS TO QUALITY AND PERFORMANCE OF THE SOFTWARE IS WITH YOU. 

GENERAL: This Agreement is the complete agreement and understanding of the parties with respect to the Software and 
supersedes all prior oral, written, or other representations and agreements. You acknowledge that the Software is of U.S. origin, 
and agree to comply with all applicable international and national laws that apply to the Software, including the U.S. Export 
Administration Regulations, as well as end-user, end-use, and country destination restrictions issued by the U.S. and other gov-
ernments. If this product is acquired under the terms of a U.S. Government contract, use, duplication, and disclosure are subject 
to the terms of this license and the restrictions contained in the Rights in Technical Data and Computer Software clause at 
252.227-7013 (DOD contracts); and subdivisions (a) through (d) of 52.227-19 as applicable. This Agreement shall be governed 
by the laws of the State of New York, without regard to its conflicts of law provisions. 

AUTHORIZED PARTIES: In addition to the License rights granted in this License Agreement, parties authorized by Licensor to 
distribute, resell, or provide software for use on Licensor’s Products (collectively “Authorized Parties”) shall have the right to 
install and sublicense the Software to End Users solely for the purpose of using the Software on Licensor’s products for the End 
User’s own business. Authorized Parties shall have the right to advertise or otherwise market the Software for use on Licensor’s 
products. User guides and programming guides for the Software that are provided by Licensor to Authorized Users in either 
hard or electronic copy may be copied and distributed. Authorized Parties shall provide this License Agreement with any subli-
cense to an End User of the Software. Authorized Parties who distribute the Software shall promptly discontinue distribution of 
the Software to any End User which does not comply with the obligations in this License Agreement and shall notify Licensor 
and cooperate with Licensor in investigating instances of violation thereof.
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